On Mon, 30 Jul 2012 01:04:34 -0500, Nasser M. Abbasi wrote:
> I prefer to use the long name of a package when I call some of its
> i.e. I really want to just write
> x * y
Which is in a clear contradiction to what you stated first. "*" is a name
of a function.
> where x,y are variables with types defined in the package, and not write
> x package_foo("*") y
Package_Foo."*" (X, Y)
> This is annoying.
There is a restricted form of use which brings up only operations of a
use type Package_Foo.Float_Type;
X, Y : Package_Foo.Float_Type;
... X * Y ... -- This is OK now
Dmitry A. Kazakov